Add kernel version check (close #185)
_NOTE: You will need to satisfy kernel requirements for Docker._ It's currently recommended to use 3.10, although 3.8 works as well. We have done some additional testing on Ubuntu Preciese, and found that the oldest kernel that Ubuntu ships and weave happily runs on is 3.5, presumably some some of the issues had been fix since Docker docs were last updated. This is not to say that kernel version is good one to use, we do recommend to use the latest, but just in case if you have any specific reason why you cannot upgrade, then the 3.5 is the oldest we have tried.
This commit is contained in:
1 parent
f073c7048c
commit
a637294f2f
1 file changed
+13
@@ -338,6 +338,19 @@ container_weave_addrs() {
|
||||
ip netns exec $NETNS ip addr show dev $CONTAINER_IFNAME
|
||||
}
|
||||
|
||||
uname_sys=`uname -s`
|
||||
uname_rel_major=`uname -r | cut -d. -f1`
|
||||
uname_rel_minor=`uname -r | cut -d. -f2`
|
||||
|
||||
[ ! $uname_sys = 'Linux' ] && {
|
||||
echo "ERROR: Operating systems other than Linux are not supported (you have $uname_sys)" >&2
|
||||
exit 1
|
||||
}
|
||||
|
||||
(([ $uname_rel_major -eq 3 ] && [ $uname_rel_minor -ge 5 ]) || [ $uname_rel_major -gt 3 ]) || {
|
||||
echo "WARNING: Linux kernel version 3.5 or newer is required (you have `uname -sr`)" >&2
|
||||
}
|
||||
|
||||
case "$COMMAND" in
|
||||
launch)
|
||||
check_not_running $CONTAINER_NAME $IMAGE
|
||||
|
||||
Reference in new issue
Block a user